Forums Archived

This forum has been archived. No new posts can be made and no new users can sign up. It remains here for reference only.

Find the new forums here

Unable to start AMP instances from ADS after management.

  • Last Post 29 July 2020
  • Topic Is Solved
kprose posted this 23 July 2020

OS Name/Version:

 Windows Server 2019 Datacenter (Desktop Experience) Build 1809 

Product Name/Version:

 AMP v2.0.3 - McMyAdmin

Problem Description:

 I currently cannot start any instances using ADS (Besides the ones I created with ADS). I just installed ADS today because I did not know it existed (Came from McMyAdmin2 originally, been running AMP for a few months), when I try to start from ADS on any pre-existing instances after managing them I get this error  "You cannot start instances you do not own as a non-root user. You are 'servername$' and this instance belongs to 'username'. Do not attempt to change the owner of an instance, this will damage your installation. Switch to the correct user and try again. ADS is installed as a service, and as such only ADS may start/stop other instances." The services report as being set as Network Service, but I don't know how to fix this, these servers have an active userbase. This server is also bound to Active Directory (I'm a home lab user) and the username is my AD account.

Steps to reproduce:

1. Have pre-existing instances
2. Install ADS
3. Manage instances
4. Attempt to start an instance

Actions taken to resolve so far:

I haven't taken any steps as I do not know what to change and also don't want to damage my instances or my server (This also runs SQL Server, Remote Desktop Services)

Order By: Standard | Newest | Votes
Mike posted this 23 July 2020

Have you swapped ADS between being a service and not being a service at some point?

kprose posted this 24 July 2020

Yes, I have. Would that be the cause? Also sorry for the late response.

Mike posted this 24 July 2020

Yes, instances created while its a service cannot be managed if its not a service, and vice-versa on Windows.

kprose posted this 24 July 2020

When I originally created all the instances I told them to be services, as well as ADS, but I did switch it out of being a service and in to test if that was the issue.

Mike posted this 25 July 2020

Only ADS should be a service. None of the others should be.

kprose posted this 26 July 2020

I uninstalled the service on one of the pre-existing instances, and I tried to start it from ADS and I get the same error, and if the instance is started from the instance manager without being a service, ADS cannot see if it is running and it just says it is off. Edit: Game Instance has service uninstalled and ADS has the service installed, also messed up on calling it ADP, been working with another program named ADP

kprose posted this 29 July 2020

I eventually fixed it but not how I wanted to. The testing instance got to the point where I could not log in to the instance. So I am just going to backup the data and recreate all the instances and restore the data.